Performance issues
Incident Report for itslearning
Postmortem

We have completed our investigations and concluded on the core of this incident. The services handling traffic taking care of our most used features like assignment and page elements ran into a complex server-to-server communication error state. The process of solving these complex situations is to start with most plausible cause and work our way through the list. For every action/change we need to test, verify and assess the results. In this instance we had to run through a set of changes before we reached our goal and got the service 100% up and running which also explains the long lifetime of this incident.

We have taken actions to prevent similar events in the future and there are other more long-term activities to further strengthen the affected service.

Posted Apr 30, 2021 - 13:43 CEST

Resolved
This incident has been resolved. The problem was due to a hosting server error.

It took us some time to identify and implement the fix due to the complexity of the problem, where our team had to ensure that the fix in each step worked before moving to the next step. We are currently also scaling up capacity on specific servers to try to remove the identified bottlenecks.

We will continue to monitor and apologize for any inconvenience this has caused you.
Posted Apr 27, 2021 - 14:51 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2021 - 14:11 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 27, 2021 - 13:09 CEST
Update
Sorry for the problems caused, we are still continuing to work on a fix for this issue.
Posted Apr 27, 2021 - 12:02 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 27, 2021 - 11:00 CEST
Update
We are continuing to work on a fix for this issue. Sorry for the inconvenience caused.
Posted Apr 27, 2021 - 10:59 CEST
Identified
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Apr 27, 2021 - 10:22 CEST
This incident affected: itslearning.