Performance issues
Incident Report for itslearning
Resolved
The issue has now been resolved. We are sorry for the inconvenience.
Posted Nov 06, 2017 - 17:54 CET
Identified
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Nov 06, 2017 - 16:52 CET