Issues with loading embedded content.
Incident Report for itslearning
Resolved
The issue has been resolved. We apologize for any inconvenience this issue may have caused.
Posted Sep 04, 2024 - 18:45 CEST
Update
We are continuing to investigate this issue.
Posted Sep 04, 2024 - 17:07 CEST
Investigating
We are aware that certain embedded content is not loading. We are investigating the issue.
Posted Sep 04, 2024 - 16:04 CEST
This incident affected: itslearning.