Critical maintenance starting soon
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 06:51 CET
Monitoring
We are continuing our efforts to improve our performance and will continue to monitor throughout the day.
Posted Mar 18, 2020 - 04:39 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2020 - 21:02 CET
Identified
Dear customer,

Unprecedented school closings around the world have resulted in extraordinary increases in usage of the Itslearning platform. As a result, Itslearning will be performing critical system upgrades today starting at 22:00 CET. During this upgrade you may not be able to access some of the features in itslearning.

Disabled features during upgrade:
Assignments
Library
Page

We are very sorry for the late notice, but we do this to help manage the current workload and provide our customers with a more stable and scalable solution going forward.
We apologize for any inconvenience that this may cause.

If you have any questions, please contact your local itslearning Support team (support.itslearning.com). We appreciate your patience and understanding.
Posted Mar 17, 2020 - 21:01 CET
This incident affected: itslearning.