Performance issues
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 17:10 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2020 - 16:49 CEST
Investigating
We are experiencing degraded performance in assignments and pages. Some users may notice some pages are taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Oct 08, 2020 - 16:31 CEST
This incident affected: itslearning.