Performance issue due to high load
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 10:15 CET
Update
All services are up and running. We will due to the special circumstances continue monitoring the situation and be ready to take appropriate actions as soon as we see sign of any performance issues.

Thank you for your understanding.
Posted Mar 17, 2020 - 09:47 CET
Update
We will continue monitoring the situation 24/7 and be ready to take appropriate actions as soon as we see sign of any performance issues.

Thank you for your understanding.
Posted Mar 16, 2020 - 16:24 CET
Monitoring
A fix has been implemented and we are monitoring the results.

We still may see some glitches with performance issues, and we will continue the work to further improve the service and capacity. Thank you for your understanding and please accept our sincere apologies for the problems caused.
Posted Mar 16, 2020 - 12:20 CET
Update
We are continuing our efforts to improve performance. These days are challenging for all and most of all you who are delivering remote teaching to your students.

We can ensure you that we are doing all we can to improve the service and we apologize for the inconvenience this may have caused.
Posted Mar 16, 2020 - 11:13 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2020 - 09:27 CET
Investigating
Dear customer,

Due to schools being closed around the world, we are experiencing unusually high traffic that has temporarily caused degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load.

Our engineers are working hard to resolve the problem and we expect to have our service up soon. We apologize for any inconvenience that this may cause. Please try again later.

We apologize for any inconvenience that this may cause.
If you have any questions, please contact your local itslearning Support team (support.itslearning.com).


Sincerely,

itslearning
Posted Mar 16, 2020 - 09:10 CET