Service outage - Library
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 13:47 CET
Investigating
We are experiencing some issues with accessing the Library feature. Some of our users may receive error messages like "An error occurred." when trying to access Library. We hope to have this issue fixed shortly.
Posted Nov 18, 2020 - 13:19 CET
This incident affected: itslearning.