Itslearning unavailable for some customers
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 13:05 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 03, 2020 - 12:59 CEST
Investigating
We are experiencing technical issues. Itslearning may be temporarily unavailable for some users. We are investigating the problem, and will fix it shortly. If you are experiencing issues, please try again later.
Posted Aug 03, 2020 - 12:22 CEST
This incident affected: itslearning.