Performance issues
Incident Report for itslearning
Resolved
Issue has been resolved, we are monitoring the results.
Posted Dec 13, 2018 - 12:02 CET
Investigating
We are experiencing degraded performance in parts of our application. Some users may not be able to access some content and pages taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Dec 13, 2018 - 11:47 CET