Performance issues
Incident Report for itslearning
Resolved
The degraded performance lasted for about 1.5 hours. We will continue to look into the data from the incident.
Posted Jun 21, 2024 - 09:20 CEST
Monitoring
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Jun 20, 2024 - 21:48 CEST
This incident affected: itslearning.