Microsoft Office files - intermittent issues

Incident Report for itslearning

Resolved

Issue was confirmed as a Microsoft service/hosting problem.
Posted May 12, 2025 - 07:17 CEST

Monitoring

All findings so far points towards intermittent problems at one of Microsoft office clusters. We have reached out to Microsoft with our findings.
Posted May 09, 2025 - 11:11 CEST

Update

We are continuing to investigate this issue.
Posted May 09, 2025 - 08:36 CEST

Investigating

We are currently investigating intermittent problems opening office files.
The first indications point towards problems on Microsoft side but we will continue our investigations.
Posted May 09, 2025 - 08:29 CEST
This incident affected: itslearning.