Performance issues
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 13:07 CET
Investigating
We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load. Our engineers are investigating the problem and will resolve it soon.
Posted Feb 02, 2021 - 12:16 CET