Reduced performance in Assignment
Incident Report for itslearning
Resolved
We have applied a fix to resolve the issue.
Posted Aug 29, 2022 - 14:27 CEST
Investigating
Users may notice some slowness when creating Assignments, or making updates in Assignment.
We are working to resolve the issue as soon as possible.
Posted Aug 29, 2022 - 14:22 CEST
This incident affected: itslearning.