Service outage
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted May 15, 2019 - 14:24 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 15, 2019 - 13:11 CEST
Investigating
We are experiencing some outages on parts of our application (Office Online). Our engineers are investigating and we will fix the problem shortly.
Posted May 15, 2019 - 12:57 CEST