Performance problems with office online - US customers
Incident Report for itslearning
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 19:33 CEST
Monitoring
A fix has been implemented and office online now works well. We will monitor the situation closely.
Posted Sep 10, 2020 - 18:34 CEST
Update
Fixing the performance issue for office online is still ongoing.
Posted Sep 10, 2020 - 18:09 CEST
Update
We are continuing to work on a fix for this issue. Office online still have performance issues impacting US customers.
Posted Sep 10, 2020 - 17:48 CEST
Identified
We are currently experiencing problems with office online (word, power point documents). A fix is being implemented to mitigate the issue. This is impacting our US customers.
Posted Sep 10, 2020 - 17:33 CEST
This incident affected: itslearning.