Critical maintenance starting soon
Incident Report for itslearning
Resolved
System Upgrades have been successfully completed.
Posted Mar 19, 2020 - 03:17 CET
Investigating
Dear customer,

Unprecedented school closings around the world have resulted in extraordinary increases in usage of the itslearning platform. As a result, itslearning will be performing critical system upgrades today starting at 23:30 CET. During this upgrade you may not be able to access some of the features in itslearning.

Disabled features during upgrade:
Assignments
Library
Page
Office online

We do this to help manage the current workload and provide our customers with a more stable and scalable solution going forward. We apologize for any inconvenience that this may cause.

If you have any questions, please contact your local itslearning Support team (support.itslearning.com). We appreciate your patience and understanding.
Posted Mar 18, 2020 - 23:08 CET
This incident affected: itslearning.