Performance issues

Incident Report for itslearning

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 14:39 CET

Update

We are continuing to monitor for any further issues.
Posted Dec 19, 2025 - 14:27 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2025 - 14:27 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 19, 2025 - 14:20 CET

Investigating

We are experiencing degraded performance in parts of our application. Some users may notice some pages are taking longer than usual to load or receive error messages in some areas of the application. Our engineers are investigating the problem and will resolve it soon.
Posted Dec 19, 2025 - 14:06 CET
This incident affected: itslearning.