Slowness and not able to enrol into courses.

Incident Report for itslearning

Resolved

The incident has been resolved. We apologize for any inconvenience.
Posted May 13, 2026 - 14:40 CEST

Identified

We have identified the issue and are working on a fix.
Posted May 13, 2026 - 13:50 CEST

Investigating

Some users are experiencing slowness or not being able to enrol, when trying to enrol into a course from the list of available courses.
We are investigating the issue.
Posted May 13, 2026 - 13:11 CEST
This incident affected: itslearning.