Some teachers not able to create or edit announcements.

Incident Report for itslearning

Resolved

A fix was released and the issue has been resolved.
Posted Feb 25, 2026 - 21:01 CET

Update

We are preparing a fix for the issue.
Posted Feb 25, 2026 - 20:24 CET

Update

We are preparing a fix for the issue.
Posted Feb 25, 2026 - 19:06 CET

Update

We are preparing a fix for the issue.
Posted Feb 25, 2026 - 18:16 CET

Update

We are preparing a fix for the issue.
Posted Feb 25, 2026 - 17:15 CET

Update

We are preparing a fix for the issue.
Posted Feb 25, 2026 - 15:48 CET

Identified

The issue has been identified and we are preparing a fix.
Posted Feb 25, 2026 - 14:55 CET

Investigating

We are aware of an issue that causes the edit field for Announcements to not show in some courses.
This applies to courses where announcements of the type "add in multiple courses" have been made.
Teachers may not see existing announcements in these courses.
Students are able to read announcements as normal.
Posted Feb 25, 2026 - 13:46 CET
This incident affected: itslearning.